Intermittent blocking of emails to clients from Solutionreach
Incident Report for Solutionreach
Resolved
We have completed the necessary updates and have resolved the prior listed email delivery issues. Some patients may see emails routing to their spam folder. In this case along with any additional email delivery concerns, please refer to our Community page - https://community.solutionreach.com/s/article/Why-are-patients-not-receiving-some-of-my-messages. We are continuing to monitor our email servers for continued delivery optimization.
Posted Feb 27, 2023 - 15:32 MST
Update
Our Engineering team is continuing to address ongoing email delivery concerns. We’ve taken several steps to mitigate delivery issues while continuing to send and monitor emails in a phased approach with positive results. The engineering team has several plans in place to continue to address message engagement, delivery and reliability of our system to ensure that messages sent through the Solutionreach system are delivered to your patient’s inbox. Please be patient with us as we continue to work through this issue.
Posted Feb 23, 2023 - 11:15 MST
Update
We have identified a major cause of the current email delivery issue. Testing, validation and rollout is currently taking place in a phased approach for email security and compliance measures. We will continue to provide updates as we work towards a resolution. Thank you for your continued patience.
Posted Feb 14, 2023 - 11:03 MST
Update
Various downstream third-party services are still currently blocking emails from Solutionreach that may be causing intermittent delivery failures. As a result, some email messages sent to Solutionreach clients and patients may not be delivered. We are actively working with these service providers to resolve the issue as quickly as possible as our top priority. We will alert you when full email delivery service is restored.
Posted Feb 13, 2023 - 12:46 MST
Update
We are continuing to investigate this issue.
Posted Jan 26, 2023 - 15:07 MST
Investigating
Various downstream third-party services are currently blocking emails from Solutionreach that may be causing intermittent delivery failures. As a result, some email messages sent to Solutionreach clients may not be delivered. This does not affect emails being sent to patients. We are actively working with these service providers to resolve the issue as quickly as possible. We will alert you when full email delivery service is restored.
Posted Jan 26, 2023 - 14:29 MST
This incident affected: Solutionreach Platform - Platform access and overall performance.