Sync Processing Failure

Incident Report for Solutionreach

Resolved

This incident has been resolved.
Posted Mar 08, 2021 - 08:50 MST

Update

Queue is back empty and all processing has caught up.

Identified ~15-20 uploads stuck in processing and are dealing with these one-by-one to get them going.

Will monitor over the weekend and close out on Monday if it remains stable.
Posted Mar 05, 2021 - 17:00 MST

Update

The upload queue has caught up. Syncs are processing normally. We will continue to monitor health and progress.
Posted Mar 05, 2021 - 14:40 MST

Update

We have confirmed that the system is up and running and uploads are processing. We have several uploads backlogged that will take some time to process through. Some delays will result because of this.

We will monitor and update and progress continues.
Posted Mar 05, 2021 - 11:23 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 05, 2021 - 11:21 MST

Identified

We are implementing a fix and will monitor results.
Posted Mar 05, 2021 - 10:01 MST

Update

Update: Initial findings are that syncs are processing, but the queue of sync uploads is backed up. Will continue investigating and finding root cause.
Posted Mar 05, 2021 - 08:59 MST

Investigating

We are investigating a problem with some syncs uploads not processing.
Posted Mar 05, 2021 - 08:44 MST
This incident affected: Sync - General stability of SR sync software and connection to client PM/EMR/EHR.